Agents with unsupported versions

  • Effective Date: March 2021
  • Announcement Date: August 2019

As of the effective date:

  • Agents in your environment with unsupported versions cannot connect.

See OpsRamp N-2 support policy for reference.

See Updating Agents on how to update your agents.

Application patching support

  • Effective Date: March 2021
  • Announcement Date: October 2020

As of the effective date, application patching for the following 3rd party applications is not supported:

  • 7-Zip
  • Adobe Reader
  • CDBurnerXP
  • Classic Shell
  • CutePDF
  • Evernote
  • FastStone
  • Foxit Reader
  • GIMP
  • Glary
  • GotoMeeting
  • IrfanView
  • iTunes 32 bit
  • iTunes 64 bit
  • Java 7 bit
  • Java 7 64 bit
  • KeePass
  • LogMeIn Hamachi
  • Malwarebytes Anti-Malware
  • Microsoft Silverlight 32 bit
  • Microsoft Silverlight 64 bit
  • Mozilla Thunderbird
  • MozyHome
  • Notepad++
  • PeaZip
  • Picasa
  • Pidgin
  • Postman
  • PrimoPDF
  • Putty
  • QuickTime
  • Safari
  • SeaMonkey
  • Skype
  • Snagit
  • Universal Extractor
  • VLC media player 32 bit
  • VLC media player 64 bit
  • VNC Server
  • WinMerge
  • XnView

Azure BizTalk Service

  • Effective Date: March 2021
  • Announcement Date: January 2021

Microsoft Azure BizTalk Service has been deprecate and migrated to Azure Logic Apps. Accordingly, OpsRamp will no longer support the discovery of BizTalk due to compatibility issues with Azure.

For more information, visit the Azure deprecation posting at Migrate your apps and solutions from BizTalk Services to Azure Logic Apps

  • Effective Date: March 2021
  • Announcement Date: May 2020

Due to the redesign of the navigation bar, the breadcrumb trails in the top navigation bar of the Setup page and Reports page will no longer be available as of the effective date.

Following this deprecation, all navigation through these modules must be done using the left side panels.

Device APIs

  • Effective Date: March 2021
  • Announcement Date: January 2019

Specific device APIs will not be accessible after the effective date; attempts to call these APIs will fail.

The following table lists the deprecated device APIs including the respective replacements:

Deprecated Device APIsReplacement Resource APIs
Create DeviceCreate Resource
Update DeviceUpdate Resource
Get DeviceGet Resource
Search DeviceSearch Resource
Delete DeviceDelete Resource
Get Minimal Device TypesGet Minimal Details of Resource Types
Get Minimal DevicesGet Minimal Details of Resources
Get Device ApplicationsGet Resource Applications

EOL for Linux versions (general)

  • Effective Date: March 2021
  • Announcement Date: November 2019

Starting with the effective date, the following Linux versions are not supported for monitoring and management functionality. These versions are already past end-of-life support from their vendor.

  • CentOS 5.x
  • Ubuntu 10.x
  • Ubuntu 11.x
  • Ubuntu 12.x
  • Ubuntu 13.x

Agents running on these versions cannot connect after the effective date.

Gateways with unsupported firmware

  • Effective Date: March 2021
  • Announcement Date: November 2019

Starting with the effective date, gateways in your environment running unsupported firmware versions cannot connect to OpsRamp.

Impacted Resources tab

  • Effective Date: March 2021
  • Announcement Date: June 2020

The Impacted Resources tab is deprecated and will not be available after the effective date.

To gain insight into resource relationships, leverage the native topology explorer. See Topology Explorer Overview for more information.

Impacted Resources tab

Impacted Resources tab

Java-based remote consoles

  • Effective Date: March 2021
  • Announcement Date: June 2020

Java-based remote consoles will not be available after the effective date. Browser-based remote consoles offer comparable functionality with more benefits.

The following protocols are deprecated:

  • File TRANSFER - Replaced by RDP Disk share
  • RMSHELL - Replaced by SSH + SFTP
  • VNC

The audit recording data for legacy java consoles is available (per the data retention policy) and is playable in the platform after the effective date.

Remote Console

Remote Console

Remote access integrations

  • Effective Date: March 2021
  • Announcement Date: June 2020

The following remote console integrations are deprecated and will not be functional as of the effective date.

  • Teamviewer
Remote Access Integrations

Remote Access Integrations